<!DOCTYPE html><html class="html" lang="en-US"><head><meta charset="UTF-8"><link rel="profile" href="https://gmpg.org/xfn/11"><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <!-- Optimized by SG Optimizer plugin version - 5.7.20 --><link rel="pingback" href="https://tjpnews.com/xmlrpc.php"><meta name="viewport" content="width=device-width, initial-scale=1"> <!-- This site is optimized with the Yoast SEO plugin v16.1.1 - https://yoast.com/wordpress/plugins/seo/ --><title>Jewish candidates seek office across North Texas - Texas Jewish Post</title><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin/><style type="text/css">@font-face {
 font-family: 'Merriweather';
 font-style: italic;
 font-weight: 300;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/merriweather/v22/u-4l0qyriQwlOrhSvowK_l5-eR7lXff4jvk.ttf) format('truetype');
}
@font-face {
 font-family: 'Merriweather';
 font-style: italic;
 font-weight: 400;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/merriweather/v22/u-4m0qyriQwlOrhSvowK_l5-eRZOf-c.ttf) format('truetype');
}
@font-face {
 font-family: 'Merriweather';
 font-style: italic;
 font-weight: 700;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/merriweather/v22/u-4l0qyriQwlOrhSvowK_l5-eR71Wvf4jvk.ttf) format('truetype');
}
@font-face {
 font-family: 'Merriweather';
 font-style: italic;
 font-weight: 900;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/merriweather/v22/u-4l0qyriQwlOrhSvowK_l5-eR7NWPf4jvk.ttf) format('truetype');
}
@font-face {
 font-family: 'Merriweather';
 font-style: normal;
 font-weight: 300;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/merriweather/v22/u-4n0qyriQwlOrhSvowK_l521wRZWMf_.ttf) format('truetype');
}
@font-face {
 font-family: 'Merriweather';
 font-style: normal;
 font-weight: 400;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/merriweather/v22/u-440qyriQwlOrhSvowK_l5-fCZJ.ttf) format('truetype');
}
@font-face {
 font-family: 'Merriweather';
 font-style: normal;
 font-weight: 700;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/merriweather/v22/u-4n0qyriQwlOrhSvowK_l52xwNZWMf_.ttf) format('truetype');
}
@font-face {
 font-family: 'Merriweather';
 font-style: normal;
 font-weight: 900;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/merriweather/v22/u-4n0qyriQwlOrhSvowK_l52_wFZWMf_.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: italic;
 font-weight: 300;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v18/memnYaGs126MiZpBA-UFUKWyV9hrIqY.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: italic;
 font-weight: 400;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v18/mem6YaGs126MiZpBA-UFUK0Zdcg.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: italic;
 font-weight: 600;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v18/memnYaGs126MiZpBA-UFUKXGUdhrIqY.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: italic;
 font-weight: 700;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v18/memnYaGs126MiZpBA-UFUKWiUNhrIqY.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: italic;
 font-weight: 800;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v18/memnYaGs126MiZpBA-UFUKW-U9hrIqY.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: normal;
 font-weight: 300;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UN_r8OUuhs.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: normal;
 font-weight: 400;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v18/mem8YaGs126MiZpBA-UFVZ0e.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: normal;
 font-weight: 600;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UNirkOUuhs.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: normal;
 font-weight: 700;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UN7rgOUuhs.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: normal;
 font-weight: 800;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UN8rsOUuhs.ttf) format('truetype');
} </style><link rel="stylesheet" id="siteground-optimizer-combined-css-40192622ebd1ee10ba7d937cb918b7bc" href="https://tjpnews.com/wp-content/uploads/siteground-optimizer-assets/siteground-optimizer-combined-css-40192622ebd1ee10ba7d937cb918b7bc.css" media="all" /><link rel="canonical" href="https://tjpnews.com/jewish-candidates-seek-office-across-north-texas/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Jewish candidates seek office across North Texas - Texas Jewish Post" /><meta property="og:description" content="Keeping the Faith The famous passage from Jeremiah 29:7 is often described as a call to action for civic engagement: “Seek the welfare of the city…for in its prosperity you [&hellip;]" /><meta property="og:url" content="https://tjpnews.com/jewish-candidates-seek-office-across-north-texas/" /><meta property="og:site_name" content="Texas Jewish Post" /><meta property="article:published_time" content="2021-04-21T19:18:14+00:00" /><meta property="article:modified_time" content="2021-04-21T19:20:07+00:00" /><meta property="og:image" content="https://tjpnews.com/wp-content/uploads/2021/04/AdobeStock_299173533.jpeg" /><meta property="og:image:width" content="2100" /><meta property="og:image:height" content="1489" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="chad@tjpnews.com"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="16 minutes"> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://tjpnews.com/#website","url":"https://tjpnews.com/","name":"Texas Jewish Post","description":"","potentialAction":[{"@type":"SearchAction","target":"https://tjpnews.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://tjpnews.com/jewish-candidates-seek-office-across-north-texas/#primaryimage","inLanguage":"en-US","url":"https://tjpnews.com/wp-content/uploads/2021/04/AdobeStock_299173533.jpeg","contentUrl":"https://tjpnews.com/wp-content/uploads/2021/04/AdobeStock_299173533.jpeg","width":2100,"height":1489,"caption":"Road sign with the map of Texas"},{"@type":"WebPage","@id":"https://tjpnews.com/jewish-candidates-seek-office-across-north-texas/#webpage","url":"https://tjpnews.com/jewish-candidates-seek-office-across-north-texas/","name":"Jewish candidates seek office across North Texas - Texas Jewish Post","isPartOf":{"@id":"https://tjpnews.com/#website"},"primaryImageOfPage":{"@id":"https://tjpnews.com/jewish-candidates-seek-office-across-north-texas/#primaryimage"},"datePublished":"2021-04-21T19:18:14+00:00","dateModified":"2021-04-21T19:20:07+00:00","author":{"@id":"https://tjpnews.com/#/schema/person/dd01a0c848793db136b82f522a7608ca"},"breadcrumb":{"@id":"https://tjpnews.com/jewish-candidates-seek-office-across-north-texas/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://tjpnews.com/jewish-candidates-seek-office-across-north-texas/"]}]},{"@type":"BreadcrumbList","@id":"https://tjpnews.com/jewish-candidates-seek-office-across-north-texas/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://tjpnews.com/","url":"https://tjpnews.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://tjpnews.com/jewish-candidates-seek-office-across-north-texas/","url":"https://tjpnews.com/jewish-candidates-seek-office-across-north-texas/","name":"Jewish candidates seek office across North Texas"}}]},{"@type":"Person","@id":"https://tjpnews.com/#/schema/person/dd01a0c848793db136b82f522a7608ca","name":"chad@tjpnews.com","image":{"@type":"ImageObject","@id":"https://tjpnews.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/efe8420aa5ba9f7f93b5fe141a9223f6?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/efe8420aa5ba9f7f93b5fe141a9223f6?s=96&d=mm&r=g","caption":"chad@tjpnews.com"}}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Texas Jewish Post &raquo; Feed" href="https://tjpnews.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Texas Jewish Post &raquo; Comments Feed" href="https://tjpnews.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Texas Jewish Post &raquo; iCal Feed" href="https://tjpnews.com/calendar/?ical=1" /><link rel="alternate" type="application/rss+xml" title="Texas Jewish Post &raquo; Jewish candidates seek office across North Texas Comments Feed" href="https://tjpnews.com/jewish-candidates-seek-office-across-north-texas/feed/" /> <!-- This site uses the Google Analytics by MonsterInsights plugin v7.17.0 - Using Analytics tracking - https://www.monsterinsights.com/ --> <!-- Note: MonsterInsights is not currently configured on this site. The site owner needs to authenticate with Google Analytics in the MonsterInsights settings panel. --> <!-- No UA code set --> <!-- / Google Analytics by MonsterInsights --> <script type='text/javascript' src='https://tjpnews.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script> <script type='text/javascript' src='https://tjpnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> <script type='text/javascript' src='https://tjpnews.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script> <script type='text/javascript' id='wp-polyfill-js-after'> ( 'fetch' in window ) || document.write( '<script src="https://tjpnews.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://tjpnews.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://tjpnews.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://tjpnews.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://tjpnews.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://tjpnews.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );( 'objectFit' in document.documentElement.style ) || document.write( '<script src="https://tjpnews.com/wp-includes/js/dist/vendor/wp-polyfill-object-fit.min.js?ver=2.3.4"></scr' + 'ipt>' ); </script> <script type='text/javascript' src='https://tjpnews.com/wp-includes/js/dist/hooks.min.js?ver=50e23bed88bcb9e6e14023e9961698c1' id='wp-hooks-js'></script> <script type='text/javascript' id='say-what-js-js-extra'> /* <![CDATA[ */
var say_what_data = {"replacements":[]};
/* ]]> */ </script> <script defer type='text/javascript' src='https://tjpnews.com/wp-content/uploads/siteground-optimizer-assets/say-what-js.min.js?ver=a79858a3a3cfa8564a1a1fb5aae4ab77' id='say-what-js-js'></script> <script defer type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-165856303-1#038;siteground-async=1' id='google_gtagjs-js' async></script> <script defer type='text/javascript' id='google_gtagjs-js-after'> window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["tjpnews.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-165856303-1", {"anonymize_ip":true}); </script><link rel="https://api.w.org/" href="https://tjpnews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://tjpnews.com/wp-json/wp/v2/posts/28034" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://tjpnews.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://tjpnews.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.7.1" /><link rel='shortlink' href='https://tjpnews.com/?p=28034' /><link rel="alternate" type="application/json+oembed" href="https://tjpnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftjpnews.com%2Fjewish-candidates-seek-office-across-north-texas%2F" /><link rel="alternate" type="text/xml+oembed" href="https://tjpnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftjpnews.com%2Fjewish-candidates-seek-office-across-north-texas%2F&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.30.0" /><meta name="follow.it-verification-code-N0ZMRjMxUHJQRnROSFBhM0JxOGhzdUtzR3g3VEhZdFYxUS83OXBveVo5MlorUmxCZDVBZUg2bFR4MnA5ZGVVcXBOUkQ0YnFrZjZLY0JjdVJKMHlHZlZ0Q3MyalRKUDNjcDRsNXNMSDlseHlxMG5tT1h3UGV1aHgzVWZ0Vlg3ejZ8dkFScFA5SHMzZTliWExzcS91ZGlQd3hUVVlpMUNieE1aZlVCajVzQmRWcz0=" content="0lzPvUrNnsdq5ux0fwgl"/><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://tjpnews.com"><link rel="https://theeventscalendar.com/" href="https://tjpnews.com/wp-json/tribe/events/v1/" /><link rel="amphtml" href="https://tjpnews.com/jewish-candidates-seek-office-across-north-texas/?amp"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-6801982206798032","enable_page_level_ads":true,"tag_partner":"site_kit"});</script><link rel="icon" href="https://tjpnews.com/wp-content/uploads/2020/03/cropped-MainLogo_sw-32x32.png" sizes="32x32" /><link rel="icon" href="https://tjpnews.com/wp-content/uploads/2020/03/cropped-MainLogo_sw-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://tjpnews.com/wp-content/uploads/2020/03/cropped-MainLogo_sw-180x180.png" /><meta name="msapplication-TileImage" content="https://tjpnews.com/wp-content/uploads/2020/03/cropped-MainLogo_sw-270x270.png" /> <style type="text/css" id="wp-custom-css"> .tribe-common--breakpoint-medium.tribe-events . tribe-events-calendar-list__event-venue{display:none !important}.tribe-common--breakpoint-medium.tribe-events .tribe-events-calendar-list__event-description{visibility:hidden !important} </style> <!-- OceanWP CSS --> <style type="text/css">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</style></head><body class="post-template-default single single-post postid-28034 single-format-standard wp-custom-logo wp-embed-responsive tribe-no-js tribe-theme-oceanwp oceanwp-theme dropdown-mobile top-header-style no-header-border default-breakpoint content-full-width content-max-width post-in-category-featured post-in-category-news has-topbar page-header-disabled has-breadcrumbs has-blog-grid elementor-default elementor-kit-18801" itemscope="itemscope" itemtype="https://schema.org/Article"><div id="outer-wrap" class="site clr"> <a class="skip-link screen-reader-text" href="#main">Skip to content</a><div id="wrap" class="clr"><div id="top-bar-wrap" class="clr"><div id="top-bar" class="clr container has-no-content"><div id="top-bar-inner" class="clr"><div id="top-bar-content" class="clr top-bar-left"><div id="top-bar-nav" class="navigation clr"><ul id="menu-topbar" class="top-bar-menu dropdown-menu sf-menu"><li id="menu-item-18815" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18815"><a href="https://tjpnews.com/advertise/" class="menu-link">Advertise</a></li><li id="menu-item-18816" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18816"><a href="https://tjpnews.com/subscribe/" class="menu-link">Subscribe</a></li><li id="menu-item-18817" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18817"><a href="https://tjpnews.com/submit-your-news/" class="menu-link">Submit Your News</a></li><li id="menu-item-18819" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18819"><a href="https://tjpnews.com/about-us/" class="menu-link">About Us</a></li><li id="menu-item-18849" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18849"><a href="https://tjpnews.com/synagogues/" class="menu-link">Synagogues</a></li></ul></div></div><!-- #top-bar-content --><div id="top-bar-social" class="clr top-bar-right"><ul class="clr" aria-label="Social links"><li class="oceanwp-twitter"><a href="https://twitter.com/tjp_news" aria-label="Twitter (opens in a new tab)" target="_blank" rel="noopener noreferrer"><span class="fab fa-twitter" aria-hidden="true"></span></a></li><li class="oceanwp-facebook"><a href="https://www.facebook.com/texasjewishpost/" aria-label="Facebook (opens in a new tab)" target="_blank" rel="noopener noreferrer"><span class="fab fa-facebook" aria-hidden="true"></span></a></li><li class="oceanwp-instagram"><a href="https://www.instagram.com/tjp_news/" aria-label="Instagram (opens in a new tab)" target="_blank" rel="noopener noreferrer"><span class="fab fa-instagram" aria-hidden="true"></span></a></li></ul></div><!-- #top-bar-social --></div><!-- #top-bar-inner --></div><!-- #top-bar --></div><!-- #top-bar-wrap --><header id="site-header" class="top-header effect-three clr" data-height="74" itemscope="itemscope" itemtype="https://schema.org/WPHeader" role="banner"><div class="header-bottom clr"><div class="container"><div id="site-logo" class="clr" itemscope itemtype="https://schema.org/Brand" ><div id="site-logo-inner" class="clr"> <a href="https://tjpnews.com/" class="custom-logo-link" rel="home"><img width="1803" height="300" src="https://tjpnews.com/wp-content/uploads/2020/03/cropped-textlogo.jpg" class="custom-logo" alt="Texas Jewish Post" srcset="https://tjpnews.com/wp-content/uploads/2020/03/cropped-textlogo.jpg 1803w, https://tjpnews.com/wp-content/uploads/2020/03/cropped-textlogo-300x50.jpg 300w, https://tjpnews.com/wp-content/uploads/2020/03/cropped-textlogo-1024x170.jpg 1024w, https://tjpnews.com/wp-content/uploads/2020/03/cropped-textlogo-768x128.jpg 768w, https://tjpnews.com/wp-content/uploads/2020/03/cropped-textlogo-1536x256.jpg 1536w" sizes="(max-width: 1803px) 100vw, 1803px" /></a></div><!-- #site-logo-inner --></div><!-- #site-logo --></div></div><div class="header-top clr"><div id="site-header-inner" class="clr container"><div class="left clr"><div class="inner"><div id="site-navigation-wrap" class="clr"><nav id="site-navigation" class="navigation main-navigation clr" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement" role="navigation" ><ul id="menu-categories" class="main-menu dropdown-menu sf-menu"><li id="menu-item-26800" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26800"><a href="https://tjpnews.com/category/news/winter-storm-2021/" class="menu-link"><span class="text-wrap">Winter Storm 2021</span></a></li><li id="menu-item-18864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18864"><a href="https://tjpnews.com/category/news/coronavirus/" class="menu-link"><span class="text-wrap">Coronavirus</span></a></li><li id="menu-item-17397" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-17397"><a href="https://tjpnews.com/category/news/" class="menu-link"><span class="text-wrap">News</span></a></li><li id="menu-item-18962" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-18962"><a href="#" class="menu-link"><span class="text-wrap">In Every Issue <span class="nav-arrow fa fa-angle-down"></span></span></a><ul class="sub-menu"><li id="menu-item-17395" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17395"><a href="https://tjpnews.com/category/around-the-town/" class="menu-link"><span class="text-wrap">Around the Town</span></a></li><li id="menu-item-17394" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17394"><a href="https://tjpnews.com/category/dallas-doings/" class="menu-link"><span class="text-wrap">Dallas Doings</span></a></li><li id="menu-item-17398" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17398"><a href="https://tjpnews.com/category/recipes/" class="menu-link"><span class="text-wrap">Recipes</span></a></li><li id="menu-item-17396" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-17396"><a href="https://tjpnews.com/category/columnists/" class="menu-link"><span class="text-wrap">Columnists<span class="nav-arrow fa fa-angle-right"></span></span></a><ul class="sub-menu"><li id="menu-item-18857" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18857"><a href="https://tjpnews.com/category/columnists/rabbi/" class="menu-link"><span class="text-wrap">Ask the Rabbi</span></a></li><li id="menu-item-18865" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18865"><a href="https://tjpnews.com/category/columnists/dispatch-from-the-homeland/" class="menu-link"><span class="text-wrap">Dispatch from the Homeland</span></a></li><li id="menu-item-18861" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18861"><a href="https://tjpnews.com/category/columnists/dvar-torah/" class="menu-link"><span class="text-wrap">D&#8217;var Torah</span></a></li><li id="menu-item-18858" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18858"><a href="https://tjpnews.com/category/columnists/historical-perspective/" class="menu-link"><span class="text-wrap">Historical Perspective by Jerry Kasten</span></a></li><li id="menu-item-18859" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18859"><a href="https://tjpnews.com/category/columnists/minds-i/" class="menu-link"><span class="text-wrap">In My Mind&#8217;s I by Harriet Gross</span></a></li><li id="menu-item-18863" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18863"><a href="https://tjpnews.com/category/columnists/rabbi-yogi/" class="menu-link"><span class="text-wrap">Rabbi Yogi</span></a></li><li id="menu-item-18860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18860"><a href="https://tjpnews.com/category/columnists/shalom/" class="menu-link"><span class="text-wrap">Shalom From the Shabbat Lady</span></a></li></ul></li><li id="menu-item-18862" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18862"><a href="https://tjpnews.com/category/opinion/" class="menu-link"><span class="text-wrap">Opinion</span></a></li></ul></li><li id="menu-item-17399" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17399"><a href="https://tjpnews.com/category/culture/" class="menu-link"><span class="text-wrap">Arts &amp; Culture</span></a></li><li id="menu-item-24529" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24529"><a href="https://tjpnews.com/category/obituaries/" class="menu-link"><span class="text-wrap">Obituaries</span></a></li><li id="menu-item-18988" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-18988"><a href="#" class="menu-link"><span class="text-wrap">Magazines <span class="nav-arrow fa fa-angle-down"></span></span></a><ul class="sub-menu"><li id="menu-item-18991" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18991"><a href="https://publisher.etype.services/Texas-Jewish-Post/e-paper-special-edition/08E8EFD1256E127A" class="menu-link"><span class="text-wrap">TJP Guide to Jewish Life</span></a></li><li id="menu-item-18989" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18989"><a href="https://publisher.etype.services/Texas-Jewish-Post/e-paper-special-edition/9270600BD3EE8499" class="menu-link"><span class="text-wrap">TJP Special Edition: Simchas 2019</span></a></li><li id="menu-item-18990" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18990"><a href="https://publisher.etype.services/Texas-Jewish-Post/e-paper-special-edition/9270600BD3EE8499" class="menu-link"><span class="text-wrap">TJP Special Edition: Healthy Living 2019</span></a></li></ul></li><li id="menu-item-19067" class="menu-item menu-item-type-post_type_archive menu-item-object-tribe_events menu-item-has-children dropdown menu-item-19067"><a href="https://tjpnews.com/calendar/" class="menu-link"><span class="text-wrap">Calendar <span class="nav-arrow fa fa-angle-down"></span></span></a><ul class="sub-menu"><li id="menu-item-19538" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19538"><a href="https://tjpnews.com/calendar/community/add" class="menu-link"><span class="text-wrap">Submit an Event</span></a></li></ul></li><li id="menu-item-20401" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20401"><a href="https://tjpnews.com/business/" class="menu-link"><span class="text-wrap">Business Directory</span></a></li></ul></nav><!-- #site-navigation --></div><!-- #site-navigation-wrap --><div class="oceanwp-mobile-menu-icon clr mobile-right"> <a href="javascript:void(0)" class="mobile-menu"  aria-label="Mobile Menu"> <i class="fa fa-bars" aria-hidden="true"></i> <span class="oceanwp-text">Menu</span> <span class="oceanwp-close-text">Close</span> </a></div><!-- #oceanwp-mobile-menu-navbar --></div></div><div class="right clr"><div class="inner"></div></div></div><!-- #site-header-inner --><div id="mobile-dropdown" class="clr" ><nav class="clr" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-categories-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26800"><a href="https://tjpnews.com/category/news/winter-storm-2021/">Winter Storm 2021</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18864"><a href="https://tjpnews.com/category/news/coronavirus/">Coronavirus</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-17397"><a href="https://tjpnews.com/category/news/">News</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18962"><a href="#">In Every Issue</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17395"><a href="https://tjpnews.com/category/around-the-town/">Around the Town</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17394"><a href="https://tjpnews.com/category/dallas-doings/">Dallas Doings</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17398"><a href="https://tjpnews.com/category/recipes/">Recipes</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-17396"><a href="https://tjpnews.com/category/columnists/">Columnists</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18857"><a href="https://tjpnews.com/category/columnists/rabbi/">Ask the Rabbi</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18865"><a href="https://tjpnews.com/category/columnists/dispatch-from-the-homeland/">Dispatch from the Homeland</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18861"><a href="https://tjpnews.com/category/columnists/dvar-torah/">D&#8217;var Torah</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18858"><a href="https://tjpnews.com/category/columnists/historical-perspective/">Historical Perspective by Jerry Kasten</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18859"><a href="https://tjpnews.com/category/columnists/minds-i/">In My Mind&#8217;s I by Harriet Gross</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18863"><a href="https://tjpnews.com/category/columnists/rabbi-yogi/">Rabbi Yogi</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18860"><a href="https://tjpnews.com/category/columnists/shalom/">Shalom From the Shabbat Lady</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18862"><a href="https://tjpnews.com/category/opinion/">Opinion</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17399"><a href="https://tjpnews.com/category/culture/">Arts &amp; Culture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24529"><a href="https://tjpnews.com/category/obituaries/">Obituaries</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18988"><a href="#">Magazines</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18991"><a href="https://publisher.etype.services/Texas-Jewish-Post/e-paper-special-edition/08E8EFD1256E127A">TJP Guide to Jewish Life</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18989"><a href="https://publisher.etype.services/Texas-Jewish-Post/e-paper-special-edition/9270600BD3EE8499">TJP Special Edition: Simchas 2019</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18990"><a href="https://publisher.etype.services/Texas-Jewish-Post/e-paper-special-edition/9270600BD3EE8499">TJP Special Edition: Healthy Living 2019</a></li></ul></li><li class="menu-item menu-item-type-post_type_archive menu-item-object-tribe_events menu-item-has-children menu-item-19067"><a href="https://tjpnews.com/calendar/">Calendar</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19538"><a href="https://tjpnews.com/calendar/community/add">Submit an Event</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20401"><a href="https://tjpnews.com/business/">Business Directory</a></li></ul><ul id="menu-topbar-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18815"><a href="https://tjpnews.com/advertise/">Advertise</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18816"><a href="https://tjpnews.com/subscribe/">Subscribe</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18817"><a href="https://tjpnews.com/submit-your-news/">Submit Your News</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18819"><a href="https://tjpnews.com/about-us/">About Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18849"><a href="https://tjpnews.com/synagogues/">Synagogues</a></li></ul><div id="mobile-menu-search" class="clr"><form method="get" action="https://tjpnews.com/" class="mobile-searchform" role="search" aria-label="Search for:"> <label for="ocean-mobile-search1"> <input type="search" name="s" autocomplete="off" placeholder="Search" /> <button type="submit" class="searchform-submit" aria-label="Submit search"> <i class="icon-magnifier" aria-hidden="true"></i> </button> </label></form></div><!-- .mobile-menu-search --></nav></div></div><!-- .header-top --></header><!-- #site-header --><main id="main" class="site-main clr"  role="main"><div id="content-wrap" class="container clr"><div id="primary" class="content-area clr"><div id="content" class="site-content clr"><article id="post-28034"><header class="entry-header clr"><h6 class="single-post-title entry-title" itemprop="headline">Jewish candidates seek office across North Texas</h6><!-- .single-post-title --></header><!-- .entry-header --><div class="entry-content clr" itemprop="text"><figure class="wp-block-image size-large"><img width="1024" height="726" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://tjpnews.com/wp-content/uploads/2021/04/AdobeStock_299173533-1024x726.jpeg" alt="" class="wp-image-28046 lazyload" data-srcset="https://tjpnews.com/wp-content/uploads/2021/04/AdobeStock_299173533-1024x726.jpeg 1024w, https://tjpnews.com/wp-content/uploads/2021/04/AdobeStock_299173533-300x213.jpeg 300w, https://tjpnews.com/wp-content/uploads/2021/04/AdobeStock_299173533-768x545.jpeg 768w, https://tjpnews.com/wp-content/uploads/2021/04/AdobeStock_299173533-1536x1089.jpeg 1536w, https://tjpnews.com/wp-content/uploads/2021/04/AdobeStock_299173533-2048x1452.jpeg 2048w" sizes="(max-width: 1024px) 100vw, 1024px" /><noscript><img width="1024" height="726" src="https://tjpnews.com/wp-content/uploads/2021/04/AdobeStock_299173533-1024x726.jpeg" alt="" class="wp-image-28046 lazyload" srcset="https://tjpnews.com/wp-content/uploads/2021/04/AdobeStock_299173533-1024x726.jpeg 1024w, https://tjpnews.com/wp-content/uploads/2021/04/AdobeStock_299173533-300x213.jpeg 300w, https://tjpnews.com/wp-content/uploads/2021/04/AdobeStock_299173533-768x545.jpeg 768w, https://tjpnews.com/wp-content/uploads/2021/04/AdobeStock_299173533-1536x1089.jpeg 1536w, https://tjpnews.com/wp-content/uploads/2021/04/AdobeStock_299173533-2048x1452.jpeg 2048w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure><h4>Keeping the Faith</h4><p>The famous passage from Jeremiah 29:7 is often described as a call to action for civic engagement: “Seek the welfare of the city…for in its prosperity you shall prosper.” With Judaism’s emphasis on taking care of the community and making the world a better place, the six Jewish hopefuls all point to their faith as a guiding principle in decision-making.</p><h2>Dallas City Council</h2><div class="wp-block-image"><figure class="alignleft size-large is-resized"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://tjpnews.com/wp-content/uploads/2021/04/headshot_with-Glasses-835x1024.jpg" alt="" class="wp-image-28035 lazyload" width="275" height="337" data-srcset="https://tjpnews.com/wp-content/uploads/2021/04/headshot_with-Glasses-835x1024.jpg 835w, https://tjpnews.com/wp-content/uploads/2021/04/headshot_with-Glasses-245x300.jpg 245w, https://tjpnews.com/wp-content/uploads/2021/04/headshot_with-Glasses-768x942.jpg 768w, https://tjpnews.com/wp-content/uploads/2021/04/headshot_with-Glasses-1252x1536.jpg 1252w, https://tjpnews.com/wp-content/uploads/2021/04/headshot_with-Glasses.jpg 1655w" sizes="(max-width: 275px) 100vw, 275px" /><noscript><img src="https://tjpnews.com/wp-content/uploads/2021/04/headshot_with-Glasses-835x1024.jpg" alt="" class="wp-image-28035 lazyload" width="275" height="337" srcset="https://tjpnews.com/wp-content/uploads/2021/04/headshot_with-Glasses-835x1024.jpg 835w, https://tjpnews.com/wp-content/uploads/2021/04/headshot_with-Glasses-245x300.jpg 245w, https://tjpnews.com/wp-content/uploads/2021/04/headshot_with-Glasses-768x942.jpg 768w, https://tjpnews.com/wp-content/uploads/2021/04/headshot_with-Glasses-1252x1536.jpg 1252w, https://tjpnews.com/wp-content/uploads/2021/04/headshot_with-Glasses.jpg 1655w" sizes="(max-width: 275px) 100vw, 275px" /></noscript></figure></div><h4>Leland Burk</h4><p>Dallas businessman Leland Burk is seeking election to the Dallas City Council representing District 13.<br>The fourth-generation Texan and lifelong resident of the district said he’s running for Council because he has a “heart for the community” and wants to serve its residents.<br>As the co-founder of First Independent National Bank and founder of his own real estate investment firm, Burk said his business and finance experience will help him guide Dallas through the difficult times the city has experienced due to COVID-19.<br>“I’ve been investing in the community for the past 35 years,” Burk said. “I’m the only [candidate] with 35 years of finance and business background, and Dallas is a 4-billion-dollar-a-year business… We need business and finance on this Council now more than ever.”<br>If elected, Burk, who is endorsed by the Dallas Police Association and Dallas Firefighters Association, said his highest priority would be public safety.<br>Dallas ended 2020 with its highest murder rate in 15 years, a statistic Burk hopes to combat through many strategies, including community-based and crime prevention initiatives. In addition to reducing the crime rate, Burk said he wants to increase public safety funding and hire more police officers.<br>“I am a firm believer that all of our opportunity and prosperity in Dallas begins and ends with public safety,” Burk said.<br>Burk was appointed by current Council Member Jennifer Staubach Gates to serve on the Northwest Highway and Preston Road Area Plan Advisory Task Force and as a commissioner on the Arts and Culture Advisory Commission of the City of Dallas. He also plans to push for repairs to the city’s streets and other aspects of infrastructure.<br>“District 13 has the highest property tax base of all the Council districts in Dallas,” Burk said. “We have the worst streets, and we deserve to have the best streets.”<br>Burk and his three children celebrated their b’nai mitzvah at Temple Emanu-El. His father recently celebrated his second bar mitzvah there at age 83.<br>“Being a member of the Jewish community has been woven into the fabric of our lives for generations,” Burk said. “For me, one of the most powerful principles of Judaism is an appreciation for both the gifts and sacrifices of past generations, as well as our responsibility to future generations of Jews. Being Jewish also comes with a special sensitivity to persecution and dehumanization of vulnerable people, and I will fight discrimination wherever I see it as a member of the Dallas City Council.”<br>Burk is running against four first-time Council candidates: Da’On Boulanger-Chatman, Ryan Moore, Mac Smith and Gay Donnell Willis.</p><p class="has-text-align-right"><strong>—Nicole Hawkins</strong></p><div class="wp-block-image"><figure class="alignleft size-large is-resized"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://tjpnews.com/wp-content/uploads/2021/04/D12_Cara-Mendelsohn-683x1024.jpg" alt="" class="wp-image-28036 lazyload" width="250" height="375" data-srcset="https://tjpnews.com/wp-content/uploads/2021/04/D12_Cara-Mendelsohn-683x1024.jpg 683w, https://tjpnews.com/wp-content/uploads/2021/04/D12_Cara-Mendelsohn-200x300.jpg 200w, https://tjpnews.com/wp-content/uploads/2021/04/D12_Cara-Mendelsohn-768x1152.jpg 768w, https://tjpnews.com/wp-content/uploads/2021/04/D12_Cara-Mendelsohn.jpg 1000w" sizes="(max-width: 250px) 100vw, 250px" /><noscript><img src="https://tjpnews.com/wp-content/uploads/2021/04/D12_Cara-Mendelsohn-683x1024.jpg" alt="" class="wp-image-28036 lazyload" width="250" height="375" srcset="https://tjpnews.com/wp-content/uploads/2021/04/D12_Cara-Mendelsohn-683x1024.jpg 683w, https://tjpnews.com/wp-content/uploads/2021/04/D12_Cara-Mendelsohn-200x300.jpg 200w, https://tjpnews.com/wp-content/uploads/2021/04/D12_Cara-Mendelsohn-768x1152.jpg 768w, https://tjpnews.com/wp-content/uploads/2021/04/D12_Cara-Mendelsohn.jpg 1000w" sizes="(max-width: 250px) 100vw, 250px" /></noscript></figure></div><h4>Cara Mendelsohn</h4><p>Cara Mendelsohn is seeking reelection for a second consecutive term to the Dallas City Council representing District 12 in Far North Dallas.<br>Mendelsohn, who was first elected to office in 2019, says she is running for a second term for the same reason she ran initially — to represent her district while serving the entire city of Dallas.<br>Mendelsohn said her biggest contribution to the city of Dallas during her first term in office was “helping move the city forward through very challenging times,” especially problems arising from the COVID-19 pandemic. Her greatest accomplishment in District 12 was securing a second fulltime ambulance, which has reduced emergency response times, she said.<br>“I dig into the briefings and the proposed programs and contracts and I ask the questions that help shape better policy, to form more effective programs and to spend our taxpayer dollars more wisely,” Mendelsohn said.<br>Mendelsohn said she is also “very proud of [her] work and leadership in expanding homeless services and sheltering in Dallas, especially as our homeless population is rising locally and across the nation.”<br>Mendelsohn previously worked in the nonprofit sector, including as director of The Samaritan Inn homeless shelter, executive director of Rebuilding Together North Texas and chair of the Collin County Homeless Coalition. This work prepared her for serving constituents, she said.<br>Leon Jacobson, a Dallas resident, business owner and campaign volunteer, first met Mendelsohn when he was looking for nonprofits to support. Mendelsohn put Jacobson in contact with the CEO of Austin Street Center, one of Dallas’s largest homeless shelters, Jacobson donated 10% of the profits from his apparel company, GuudWEAR, to the shelter.<br>Jacobson described Mendelsohn as nonpartisan in her mindset.<br>“She really just cares about helping people all over the city and doesn’t put politics in the way of that,” Jacobson said.<br>Mendelsohn said her Jewish faith has played a role in her work as a council member. “When you serve, it’s a reflection of who you are, and my Jewish faith and education mean I was raised learning about ethics and compassion, service to others and hard work,” Mendelsohn said. These values are also present in her campaign platform, which is focused on “ethics, leadership and accountability.”<br>Mendelsohn, who grew up in District 12, said she has a long history of service in the district and is thankful for the widespread support she has received in her reelection campaign.<br>Mendelsohn is running against first-time City Council candidate Elva Curl. Curl previously served in the Dallas City Manager’s office, the Department of Aviation and the Department of Public Works.</p><p class="has-text-align-right"><strong>—Nicole Hawkins</strong></p><div class="wp-block-image"><figure class="alignleft size-large is-resized"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://tjpnews.com/wp-content/uploads/2021/04/js-2513-2-2-942x1024.jpg" alt="" class="wp-image-28038 lazyload" width="278" height="301" data-srcset="https://tjpnews.com/wp-content/uploads/2021/04/js-2513-2-2-942x1024.jpg 942w, https://tjpnews.com/wp-content/uploads/2021/04/js-2513-2-2-276x300.jpg 276w, https://tjpnews.com/wp-content/uploads/2021/04/js-2513-2-2-768x835.jpg 768w, https://tjpnews.com/wp-content/uploads/2021/04/js-2513-2-2-1412x1536.jpg 1412w, https://tjpnews.com/wp-content/uploads/2021/04/js-2513-2-2-1883x2048.jpg 1883w" sizes="(max-width: 278px) 100vw, 278px" /><noscript><img src="https://tjpnews.com/wp-content/uploads/2021/04/js-2513-2-2-942x1024.jpg" alt="" class="wp-image-28038 lazyload" width="278" height="301" srcset="https://tjpnews.com/wp-content/uploads/2021/04/js-2513-2-2-942x1024.jpg 942w, https://tjpnews.com/wp-content/uploads/2021/04/js-2513-2-2-276x300.jpg 276w, https://tjpnews.com/wp-content/uploads/2021/04/js-2513-2-2-768x835.jpg 768w, https://tjpnews.com/wp-content/uploads/2021/04/js-2513-2-2-1412x1536.jpg 1412w, https://tjpnews.com/wp-content/uploads/2021/04/js-2513-2-2-1883x2048.jpg 1883w" sizes="(max-width: 278px) 100vw, 278px" /></noscript></figure></div><h4>Jaynie Schultz</h4><p>Jaynie Schultz, a longtime Dallas resident, chairs the city’s Urban Design Advisory Committee and is president of the Dallas ISD CityLab High School Foundation. She was a Dallas City Planning Commissioner for six years. She was president of the Hillcrest Forest Neighborhood Association Board and Texas Women’s Foundation, among others.<br>In the Jewish community, she’s been active with the Jewish Federation of Greater Dallas, Akiba and Yavneh academies (now Akiba Yavneh), Moishe House Dallas and more.<br>A mother of four, she founded Garrett Creek Ranch Conference Center, Retreat Central and other businesses. She and her family are members of Shaare Tefilla.<br>So what hasn’t Schultz done?<br>Until this year, run for elected office.<br>Now, with Lee Kleinman term-limited, she has her sights on the open council seat in District 11.<br>Running for public office was not something she would’ve imagined doing in 1975 as a 15-year-old student at Skyline High School. But Levi Davis, the city’s first Black assistant city manager, spoke at the school one day. That’s when she was hooked on local government. After the talk, she recalled, “I told my parents I wanted to be a city manager.”<br>After graduating from Skyline, she received her bachelor’s degree in government from the University of Texas at Austin and her master’s in urban studies from the University of Texas at Arlington.<br>Running for council may not have been on her agenda in high school, but is the culmination of her professional life, one she described as dedicated to community building.<br>To digest all the issues facing the Northern Dallas district, she’s reached out to neighborhood associations about their needs.<br>“Our district has incredible leadership and I want to build on that,” she said.<br>She also wants residents to become more involved. One goal is to develop a district leadership development program similar to one at the Jewish Federation of Greater Dallas.<br>“It would train leaders to get involved with the city as well as their nonprofits, schools and their communities. They’d work with existing leaders to understand how these organizations build,” she said.<br>There are endless ways to get involved at the community level.<br>She wants to also focus on creating strong ties with city staff and the community, as well as among Council members. “We worked hard on Planning to create a collegial culture. That’s what I want to bring to Council,” she said. “I loved Planning, even when it was contentious.”<br>She stressed the need for collaboration and open communication at City Hall, which has experienced its share of infighting between elected officials and staff, as well as between Council members. “I talked then and still do now about the importance of communication as well as collaborating with the city manager and staff. We need to work with the officials who manage the city.”<br>The city has increased its focus on “resilience” for the past decade, an emerging movement focused on preparing for economic, natural and social challenges that could occur. Five years ago as part of an agreement with the Rockefeller Foundation, Theresa O’Donnell was named Chief Resilience Officer. That role is now held by Genesis D. Gavino.<br>Schultz stresses the need to focus on resilience now, in light of the ongoing pandemic and February winter storm that nearly knocked out the state’s energy grid.<br>Another goal is to strengthen connections between the city and school district. They may be structurally different silos, as required by state law, but “there’s nothing saying we can’t collaborate.”<br>That’s how she got involved with the Dallas ISD CityLab High School Foundation, the nonprofit supporting CityLab High School, one of the schools in the DISD’s Choice program.<br>During the 2020 elections, many candidates did not block-walk and instead relied on digital and other forms of campaigning allowing for social distancing. Schultz has chosen to block-walk while wearing a mask. But she misses one part of the usual campaign: group events.<br>“The hardest part is there are no gatherings,” she said. But she’s adjusted and has been able to do some community work, such as a COVID-19 vaccine drive for seniors and those in affordable housing.<br>“Everything I do is about building community. It always has been,” she said.<br>She faces Candy Evans, Hosanna Yemiru and Barry Wernick.</p><p class="has-text-align-right"><strong>—James Russell</strong></p><div class="wp-block-image"><figure class="alignleft size-large is-resized"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://tjpnews.com/wp-content/uploads/2021/04/Printable-CMYK-925x1024.jpg" alt="" class="wp-image-28039 lazyload" width="290" height="320" data-srcset="https://tjpnews.com/wp-content/uploads/2021/04/Printable-CMYK-925x1024.jpg 925w, https://tjpnews.com/wp-content/uploads/2021/04/Printable-CMYK-271x300.jpg 271w, https://tjpnews.com/wp-content/uploads/2021/04/Printable-CMYK-768x850.jpg 768w, https://tjpnews.com/wp-content/uploads/2021/04/Printable-CMYK-1388x1536.jpg 1388w, https://tjpnews.com/wp-content/uploads/2021/04/Printable-CMYK-1850x2048.jpg 1850w" sizes="(max-width: 290px) 100vw, 290px" /><noscript><img src="https://tjpnews.com/wp-content/uploads/2021/04/Printable-CMYK-925x1024.jpg" alt="" class="wp-image-28039 lazyload" width="290" height="320" srcset="https://tjpnews.com/wp-content/uploads/2021/04/Printable-CMYK-925x1024.jpg 925w, https://tjpnews.com/wp-content/uploads/2021/04/Printable-CMYK-271x300.jpg 271w, https://tjpnews.com/wp-content/uploads/2021/04/Printable-CMYK-768x850.jpg 768w, https://tjpnews.com/wp-content/uploads/2021/04/Printable-CMYK-1388x1536.jpg 1388w, https://tjpnews.com/wp-content/uploads/2021/04/Printable-CMYK-1850x2048.jpg 1850w" sizes="(max-width: 290px) 100vw, 290px" /></noscript></figure></div><h4>Barry Wernick</h4><p>Barry Wernick has never had a problem standing up against injustice.<br>As student body president at St. Mark’s School of Texas in the late ‘80s, he led the charge against holding an event at a country club barring people of color and Jewish people from membership.<br>“It was awful,” he said. “It was the ultimate blow. I said, ‘We’re going to have this at a place where my Black friends and myself are not allowed.’”<br>The 18-year-old’s objections were frowned upon by school and community leaders. “They were telling me to lie low and don’t make waves.” He didn’t. The students voted and decided to hold the event at a more inclusive venue.<br>Now he wants to stand up for injustices across Dallas as candidate for Council District 11. He is one of four candidates running to succeed term-limited Councilman Lee Kleinman. He faces Candy Evans, Hosanna Yemiru and Jaynie Schultz.<br>Public safety is the lawyer’s and mediator’s number one issue.<br>“Businesses don’t open in neighborhoods with bullets,” he said. “And crime doesn’t know district lines.”<br>He loves his city, but he doesn’t love the direction it’s going, he said, worried about the uptick in violent crime and human trafficking. His public safety-first platform earned him the endorsement of the Dallas Police Association. In a statement, DPA President Mike Mata said Wernick “understands the dangers of our profession and will help make sure we have the training and tools needed to keep violent crime away from North Dallas.”<br>Wernick said he would also bring his training as a mediator to solve issues facing the city. “This is what I try to do: solve cases,” he said.<br>He said he learned to be tough and passionate as one of four children of a single mother. Diane Benjamin emphasized education, and he took his studies seriously. He attended Akiba Academy and graduated from St. Mark’s School. He went onto study international relations and linguistics at the University of Texas, where he was recruited by the U.S. Air Force and Army Russian linguists to study at Trinity University. He also studied at the Moscow Power College in Russia.<br>After working in the Israeli Ministry of Justice and the Immigration Ministry, he moved back to Texas and graduated from the Dedman School of Law at SMU in 1998.<br>Wernick is also an actor and filmmaker. After he passed the bar, he left Dallas and set his sights on New York City. He picked up minor and stand-in roles, including as Mr. Big in the TV show “Sex and the City.”<br>Wernick returned to Dallas 13 years ago, and began to combine his filmmaking skills with his legal training. He produced the “Justice for Jennifer” documentary television series investigating the 18-year-old cold-case murder of his sister-in-law. He also produced an award-winning educational video for children facing abusers in court, which he says is still being used by the Dallas District Attorney’s office and other DA offices throughout the country.<br>In his free time, he is involved with Operation Underground Railroad Abolitionist Club and the Men’s Advocacy Group of New Friends New Life. Both assist in rescuing and working with survivors of human trafficking.<br>Wernick and his wife Alyssa are the parents of three daughters.<br>To him, what’s good for District 11 is good for the whole city, he said. “I’m united for Dallas for the greater good.”</p><p class="has-text-align-right"><strong>—James Russell</strong></p><h2>Fort Worth City Council</h2><div class="wp-block-image"><figure class="alignleft size-large is-resized"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://tjpnews.com/wp-content/uploads/2021/04/Beck-2-831x1024.jpeg" alt="" class="wp-image-28041 lazyload" width="319" height="393" data-srcset="https://tjpnews.com/wp-content/uploads/2021/04/Beck-2-831x1024.jpeg 831w, https://tjpnews.com/wp-content/uploads/2021/04/Beck-2-243x300.jpeg 243w, https://tjpnews.com/wp-content/uploads/2021/04/Beck-2-768x947.jpeg 768w, https://tjpnews.com/wp-content/uploads/2021/04/Beck-2-1246x1536.jpeg 1246w, https://tjpnews.com/wp-content/uploads/2021/04/Beck-2-1661x2048.jpeg 1661w" sizes="(max-width: 319px) 100vw, 319px" /><noscript><img src="https://tjpnews.com/wp-content/uploads/2021/04/Beck-2-831x1024.jpeg" alt="" class="wp-image-28041 lazyload" width="319" height="393" srcset="https://tjpnews.com/wp-content/uploads/2021/04/Beck-2-831x1024.jpeg 831w, https://tjpnews.com/wp-content/uploads/2021/04/Beck-2-243x300.jpeg 243w, https://tjpnews.com/wp-content/uploads/2021/04/Beck-2-768x947.jpeg 768w, https://tjpnews.com/wp-content/uploads/2021/04/Beck-2-1246x1536.jpeg 1246w, https://tjpnews.com/wp-content/uploads/2021/04/Beck-2-1661x2048.jpeg 1661w" sizes="(max-width: 319px) 100vw, 319px" /></noscript></figure></div><h4>Elizabeth Beck</h4><p>Elizabeth Beck has stepped into the race for the open District 9 council seat in Fort Worth, a centrally located district which includes downtown and Near Southside. The position was vacated by Ann Zadeh, who is running for mayor.<br>Beck, a Fort Worth resident who was defeated in her race for the Texas House of Representatives last year, is backed by the Fort Worth Firefighters Association and Sierra Club and received the Fort Worth Star-Telegram Editorial Board’s endorsement.<br>She faces five other candidates.<br>The race has been eventful. Candidate Erik Richerson was found ineligible because of a past criminal conviction. Another candidate, Darien George, withdrew after lashing out at opponent Jordan Mims and yelling at others during a forum. According to the Star-Telegram, Beck inserted herself between the two men.<br>Beck knows how to tackle tough situations. She enlisted in the Army Reserves when she was 17 and was deployed to Iraq. She came back, enrolled in the University of Texas at Arlington and finished her undergraduate degree. Three weeks before finishing, she gave birth to her daughter. She went on to earn her master’s degree in city and regional planning at UTA and then a law degree at Texas A&amp;M School of Law.<br>She is involved with Planned Parenthood of Greater Texas and Annie’s List, which trains Democratic women to run for office. She also serves on the board of Beth-El Congregation.<br>Even though she already has a full plate, she said her faith compels her to continue to serve her community.<br>“We’re asked how we can make the world a better place. It’s not enough to be a good person and do no harm. The imperative is to fix something,” she said. Running for office is a “natural progression” from the kinds of roles she has had in the community, she said.<br>If elected she’s prioritizing infrastructure, including transit and city services, to support and attract businesses and residents. She is also focused on addressing a looming affordable housing crisis and diversifying the city’s economy by fostering entrepreneurship.<br>“Fort Worth is home for me, not only because it’s the place I’ve called home my entire life, but because it’s a great place to live,” she said. “Fort Worth has amazing people, vibrant neighborhoods, and a strong sense of community.</p><p class="has-text-align-right"><strong>—James Russell</strong></p><h2>Plano City Council</h2><div class="wp-block-image"><figure class="alignleft size-large is-resized"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://tjpnews.com/wp-content/uploads/2021/04/Steve-Lavine-Head-Shot-Campaign.jpeg" alt="" class="wp-image-28042 lazyload" width="317" height="349" data-srcset="https://tjpnews.com/wp-content/uploads/2021/04/Steve-Lavine-Head-Shot-Campaign.jpeg 550w, https://tjpnews.com/wp-content/uploads/2021/04/Steve-Lavine-Head-Shot-Campaign-272x300.jpeg 272w" sizes="(max-width: 317px) 100vw, 317px" /><noscript><img src="https://tjpnews.com/wp-content/uploads/2021/04/Steve-Lavine-Head-Shot-Campaign.jpeg" alt="" class="wp-image-28042 lazyload" width="317" height="349" srcset="https://tjpnews.com/wp-content/uploads/2021/04/Steve-Lavine-Head-Shot-Campaign.jpeg 550w, https://tjpnews.com/wp-content/uploads/2021/04/Steve-Lavine-Head-Shot-Campaign-272x300.jpeg 272w" sizes="(max-width: 317px) 100vw, 317px" /></noscript></figure></div><h4>Steve Lavine</h4><p>Steve Lavine moved to Plano in 1983 and noticed immediately how similar it was to his hometown of Skokie, Illinois.<br>“While I was growing up there, Skokie was growing and building out — adding housing, schools, shopping and other amenities at a swift pace — while being close to the culture provided by Chicago,” he said.<br>“I was attracted to Plano as a place where my family and I could grow up with the city. I’ve enjoyed looking forward to another great new city service, restaurant, program, shopping spot, or other amenity just about every year. Plus, being close to Dallas and Fort Worth gives us access to a wide range of other cultural amenities,” he said.<br>With Plano’s growth since the 1980s, he’s running for City Council “to tackle our city’s maturity head-on.”<br>That includes expanding the city’s tax base. He’s worried the current policy of discouraging new revenue streams could hurt Plano’s homeowners and economy.<br>“Shortchanging Plano now will cost homeowners more later and hamper our ability to keep up with other North Texas cities that may attract away our corporate citizens. To keep and attract these companies and their employees we must be forward-thinking and maintain our open mind on equal rights, inclusivity and other issues of importance to all our citizens,” he said.<br>Other priorities include providing a safe environment and supporting police and firefighters.<br>“We must continue to invest in our police and fire departments to keep their equipment up to date and hold on to the top management and the experienced personnel who keep our city one of the safest in America,” he said.<br>He’s served in various roles with the city and in community, including as chairman of the Library Advisory Board and on the Parks and Recreation board. He’s volunteered with the Boy Scouts, and served as a board member for Plano Youth Leadership and the Friends of the Plano Public Library as well on the board of his homeowner’s association, Avignon Windhaven, including a recent stint as president.<br>He was also active at Temple Shalom while raising his children. He now occasionally attends Adat Chaverim in Plano. “The Jewish religion is centered around the concepts of being humble, generous and caring. ‘Love your neighbor as you would love yourself’ refers to loving yourself and learning to love and accept others the same way,” he said.<br>Lavine said that Judaism’s emphasis on serving the community helps to inform his decisions.<br>“My essential guidepost is that ‘it’s not about me.’ After my family life, servant leadership is the most rewarding role in my life. I started early as an active Boy Scout (a role I continue as an adult leader today), and continue in my service to my community, schools, profession and neighborhood,” he said. “Morality is a combination of good deeds, thoughts, intentions, attitudes and actions. That’s how I strive to live my life.”<br>Lavine is facing incumbent council member Anthony Ricciardelli in the May 4 contest.</p><p class="has-text-align-right"><strong>—James Russell</strong></p><p><em>Early voting will continue through April 27 and the general election is May 1. For more voting and election information, visit dallascityhall.com.</em></p></div><!-- .entry --><ul class="meta ospm-default clr"><li class="meta-date" itemprop="datePublished"><span class="screen-reader-text">Post published:</span><i class="icon-clock" aria-hidden="true"></i>April 21, 2021</li><li class="meta-cat"><span class="screen-reader-text">Post category:</span><i class="icon-folder" aria-hidden="true"></i><a href="https://tjpnews.com/category/featured/" rel="category tag">Featured</a> <span class="owp-sep">/</span> <a href="https://tjpnews.com/category/news/" rel="category tag">News</a></li><li class="meta-comments"><span class="screen-reader-text">Post comments:</span><i class="icon-bubble" aria-hidden="true"></i><a href="https://tjpnews.com/jewish-candidates-seek-office-across-north-texas/#respond" class="comments-link" >0 Comments</a></li></ul><div class="post-tags clr"></div><section id="related-posts" class="clr"><h3 class="theme-heading related-posts-title"> <span class="text">You Might Also Like</span></h3><div class="oceanwp-row clr"><article class="related-post clr col span_1_of_3 col-1 post-6196 post type-post status-publish format-standard hentry category-featured entry"><h3 class="related-post-title"> <a href="https://tjpnews.com/helping-hands-handle-it/" title="Helping hands handle it" rel="bookmark">Helping hands handle it</a></h3><!-- .related-post-title --> <time class="published" datetime="2013-01-03T02:00:55-06:00"><i class="icon-clock" aria-hidden="true"></i>January 3, 2013</time></article><!-- .related-post --><article class="related-post clr col span_1_of_3 col-2 post-17060 post type-post status-publish format-standard hentry category-news entry"><h3 class="related-post-title"> <a href="https://tjpnews.com/5-jewish-things-to-know-about-joe-biden/" title="5 Jewish things to know about Joe Biden" rel="bookmark">5 Jewish things to know about Joe Biden</a></h3><!-- .related-post-title --> <time class="published" datetime="2019-04-25T08:11:57-05:00"><i class="icon-clock" aria-hidden="true"></i>April 25, 2019</time></article><!-- .related-post --><article class="related-post clr col span_1_of_3 col-3 post-7989 post type-post status-publish format-standard hentry category-featured entry"><h3 class="related-post-title"> <a href="https://tjpnews.com/pivotal-move/" title="Pivotal move" rel="bookmark">Pivotal move</a></h3><!-- .related-post-title --> <time class="published" datetime="2014-02-06T02:00:09-06:00"><i class="icon-clock" aria-hidden="true"></i>February 6, 2014</time></article><!-- .related-post --></div><!-- .oceanwp-row --></section><!-- .related-posts --><section id="comments" class="comments-area clr has-comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/jewish-candidates-seek-office-across-north-texas/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://tjpnews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="comment-textarea"><label for="comment" class="screen-reader-text">Comment</label><textarea name="comment" id="comment" cols="39" rows="4" tabindex="0" class="textarea-comment" placeholder="Your comment here..."></textarea></div><div class="comment-form-author"><label for="author" class="screen-reader-text">Enter your name or username to comment</label><input type="text" name="author" id="author" value="" placeholder="Name (required)" size="22" tabindex="0" aria-required="true" class="input-name" /></div><div class="comment-form-email"><label for="email" class="screen-reader-text">Enter your email address to comment</label><input type="text" name="email" id="email" value="" placeholder="Email (required)" size="22" tabindex="0" aria-required="true" class="input-email" /></div><div class="comment-form-url"><label for="url" class="screen-reader-text">Enter your website URL (optional)</label><input type="text" name="url" id="url" value="" placeholder="Website" size="22" tabindex="0" class="input-website" /></div><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><div class="anr_captcha_field"><div id="anr_captcha_field_1" class="anr_captcha_field_div"><input type="hidden" name="g-recaptcha-response" value="" /></div></div><p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='28034' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div><!-- #respond --></section><!-- #comments --></article></div><!-- #content --></div><!-- #primary --></div><!-- #content-wrap --></main><!-- #main --><footer id="footer" class="site-footer" itemscope="itemscope" itemtype="https://schema.org/WPFooter" role="contentinfo"><div id="footer-inner" class="clr"><div id="footer-bottom" class="clr"><div id="footer-bottom-inner" class="container clr"><div id="footer-bottom-menu" class="navigation clr"><div class="menu-topbar-container"><ul id="menu-topbar-2" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18815"><a href="https://tjpnews.com/advertise/">Advertise</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18816"><a href="https://tjpnews.com/subscribe/">Subscribe</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18817"><a href="https://tjpnews.com/submit-your-news/">Submit Your News</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18819"><a href="https://tjpnews.com/about-us/">About Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18849"><a href="https://tjpnews.com/synagogues/">Synagogues</a></li></ul></div></div><!-- #footer-bottom-menu --></div><!-- #footer-bottom-inner --></div><!-- #footer-bottom --></div><!-- #footer-inner --></footer><!-- #footer --></div><!-- #wrap --></div><!-- #outer-wrap --> <a id="scroll-top" class="scroll-top-right" href="#"><span class="fa fa-arrow-up" aria-label="Scroll to the top of the page"></span></a> <!--facebook like and share js --><div id="fb-root"></div> <script> (function(d, s, id) {
 var js, fjs = d.getElementsByTagName(s)[0];
 if (d.getElementById(id)) return;
 js = d.createElement(s);
 js.id = id;
 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5";
 fjs.parentNode.insertBefore(js, fjs);
 }(document, 'script', 'facebook-jssdk')); </script> <script> window.addEventListener('sfsi_functions_loaded', function() {
 if (typeof sfsi_responsive_toggle == 'function') {
 sfsi_responsive_toggle(0);
 // console.log('sfsi_responsive_toggle');  }
}) </script> <script> window.addEventListener('sfsi_functions_loaded', function() {
 if (typeof sfsi_plugin_version == 'function') {
 sfsi_plugin_version(2.63);
 }
 });  function sfsi_processfurther(ref) {
 var feed_id = 'N0ZMRjMxUHJQRnROSFBhM0JxOGhzdUtzR3g3VEhZdFYxUS83OXBveVo5MlorUmxCZDVBZUg2bFR4MnA5ZGVVcXBOUkQ0YnFrZjZLY0JjdVJKMHlHZlZ0Q3MyalRKUDNjcDRsNXNMSDlseHlxMG5tT1h3UGV1aHgzVWZ0Vlg3ejZ8dkFScFA5SHMzZTliWExzcS91ZGlQd3hUVVlpMUNieE1aZlVCajVzQmRWcz0=';
 var feedtype = 8;
 var email = jQuery(ref).find('input[name="email"]').val();
 var filter = /^([a-zA-Z0-9_\.\-])+\@(([a-zA-Z0-9\-])+\.)+([a-zA-Z0-9]{2,4})+$/;
 if ((email != "Enter your email") && (filter.test(email))) {
 if (feedtype == "8") {
 var url = "https://api.follow.it/subscription-form/" + feed_id + "/" + feedtype;
 window.open(url, "popupwindow", "scrollbars=yes,width=1080,height=760");
 return true;
 }
 } else {
 alert("Please enter email address");
 jQuery(ref).find('input[name="email"]').focus();
 return false;
 }
 } </script> <style type="text/css" aria-selected="true"> .sfsi_subscribe_Popinner {
 width: 100% !important;  height: auto !important;  padding: 18px 0px !important;  background-color: #ffffff !important;  }  .sfsi_subscribe_Popinner form {  margin: 0 20px !important;  }  .sfsi_subscribe_Popinner h5 {  font-family: Helvetica,Arial,sans-serif !important;  font-weight: bold !important;  color: #000000 !important;  font-size: 16px !important;  text-align: center !important;  margin: 0 0 10px !important;  padding: 0 !important;  }  .sfsi_subscription_form_field {  margin: 5px 0 !important;  width: 100% !important;  display: inline-flex;  display: -webkit-inline-flex;  }  .sfsi_subscription_form_field input {  width: 100% !important;  padding: 10px 0px !important;  }  .sfsi_subscribe_Popinner input[type=email] {  font-family: Helvetica,Arial,sans-serif !important;  font-style: normal !important;  color: #000000 !important;  font-size: 14px !important;  text-align: center !important;  }  .sfsi_subscribe_Popinner input[type=email]::-webkit-input-placeholder {  font-family: Helvetica,Arial,sans-serif !important;  font-style: normal !important;  color: #000000 !important;  font-size: 14px !important;  text-align: center !important;  }  .sfsi_subscribe_Popinner input[type=email]:-moz-placeholder {
 /* Firefox 18- */  font-family: Helvetica,Arial,sans-serif !important;  font-style: normal !important;  color: #000000 !important;  font-size: 14px !important;  text-align: center !important;  }  .sfsi_subscribe_Popinner input[type=email]::-moz-placeholder {
 /* Firefox 19+ */  font-family: Helvetica,Arial,sans-serif !important;  font-style: normal !important;  color: #000000 !important;  font-size: 14px !important;  text-align: center !important;  }  .sfsi_subscribe_Popinner input[type=email]:-ms-input-placeholder {  font-family: Helvetica,Arial,sans-serif !important;  font-style: normal !important;  color: #000000 !important;  font-size: 14px !important;  text-align: center !important;  }  .sfsi_subscribe_Popinner input[type=submit] {  font-family: Helvetica,Arial,sans-serif !important;  font-weight: bold !important;  color: #000000 !important;  font-size: 16px !important;  text-align: center !important;  background-color: #dedede !important;  }  .sfsi_shortcode_container {
 float: left;
 }  .sfsi_shortcode_container .norm_row .sfsi_wDiv {
 position: relative !important;
 }  .sfsi_shortcode_container .sfsi_holders {
 display: none;
 } </style> <script> ( function ( body ) {
 'use strict';
 body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
 } )( document.body ); </script> <script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><script defer type='text/javascript' src='https://tjpnews.com/wp-content/plugins/post-carousel-slider-for-elementor/assets/vendors/slick/slick.min.js?ver=1.0.0' id='wb-slick-library-js'></script> <script defer type='text/javascript' src='https://tjpnews.com/wp-content/uploads/siteground-optimizer-assets/wb-ps-main.min.js?ver=1.0.0' id='wb-ps-main-js'></script> <script defer type='text/javascript' src='https://tjpnews.com/wp-content/plugins/sg-cachepress/assets/js/lazysizes.min.js?ver=5.7.20' id='siteground-optimizer-lazy-sizes-js-js'></script> <script defer type='text/javascript' src='https://tjpnews.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script> <script defer type='text/javascript' src='https://tjpnews.com/wp-content/plugins/ultimate-social-media-icons/js/shuffle/modernizr.custom.min.js?ver=5.7.1' id='SFSIjqueryModernizr-js'></script> <script defer type='text/javascript' src='https://tjpnews.com/wp-content/plugins/ultimate-social-media-icons/js/shuffle/jquery.shuffle.min.js?ver=5.7.1' id='SFSIjqueryShuffle-js'></script> <script defer type='text/javascript' src='https://tjpnews.com/wp-content/uploads/siteground-optimizer-assets/SFSIjqueryrandom-shuffle.min.js?ver=5.7.1' id='SFSIjqueryrandom-shuffle-js'></script> <script type='text/javascript' id='SFSICustomJs-js-extra'> /* <![CDATA[ */
var sfsi_icon_ajax_object = {"ajax_url":"https:\/\/tjpnews.com\/wp-admin\/admin-ajax.php"};
var sfsi_icon_ajax_object = {"ajax_url":"https:\/\/tjpnews.com\/wp-admin\/admin-ajax.php","plugin_url":"https:\/\/tjpnews.com\/wp-content\/plugins\/ultimate-social-media-icons\/"};
/* ]]> */ </script> <script defer type='text/javascript' src='https://tjpnews.com/wp-content/uploads/siteground-optimizer-assets/SFSICustomJs.min.js?ver=5.7.1' id='SFSICustomJs-js'></script> <script defer type='text/javascript' src='https://tjpnews.com/wp-includes/js/comment-reply.min.js?ver=5.7.1' id='comment-reply-js'></script> <script defer type='text/javascript' src='https://tjpnews.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script> <script defer type='text/javascript' src='https://tjpnews.com/wp-content/themes/oceanwp/assets/js/third/magnific-popup.min.js?ver=2.0.2' id='magnific-popup-js'></script> <script defer type='text/javascript' src='https://tjpnews.com/wp-content/themes/oceanwp/assets/js/third/lightbox.min.js?ver=2.0.2' id='oceanwp-lightbox-js'></script> <script type='text/javascript' id='oceanwp-main-js-extra'> /* <![CDATA[ */
var oceanwpLocalize = {"isRTL":"","menuSearchStyle":"disabled","sidrSource":null,"sidrDisplace":"1","sidrSide":"left","sidrDropdownTarget":"link","verticalHeaderTarget":"link","customSelects":".woocommerce-ordering .orderby, #dropdown_product_cat, .widget_categories select, .widget_archive select, .single-product .variations_form .variations select","ajax_url":"https:\/\/tjpnews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */ </script> <script defer type='text/javascript' src='https://tjpnews.com/wp-content/themes/oceanwp/assets/js/main.min.js?ver=2.0.2' id='oceanwp-main-js'></script> <script defer type='text/javascript' src='https://tjpnews.com/wp-content/plugins/ocean-posts-slider/assets/js/main.min.js' id='ops-js-scripts-js'></script> <script type='text/javascript' src='https://tjpnews.com/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script> <!--[if lt IE 9]> <script type='text/javascript' src='https://tjpnews.com/wp-content/themes/oceanwp/assets/js/third/html5.min.js?ver=2.0.2' id='html5shiv-js'></script> <![endif]--> <script src="https://www.google.com/recaptcha/api.js?render=6LcCVeQUAAAAAHefhYe4TRhb-rjtRn_G8a95Vtcg"></script> <script type="text/javascript"> ( function( grecaptcha ) {  var anr_onloadCallback = function() {
 grecaptcha.execute(
 '6LcCVeQUAAAAAHefhYe4TRhb-rjtRn_G8a95Vtcg',
 { action: 'advanced_nocaptcha_recaptcha' }
 ).then( function( token ) {
 for ( var i = 0; i < document.forms.length; i++ ) {
 var form = document.forms[i];
 var captcha = form.querySelector( 'input[name="g-recaptcha-response"]' );
 if ( null === captcha )
 continue;  captcha.value = token;
 }
 });
 };  grecaptcha.ready( anr_onloadCallback );  document.addEventListener( 'wpcf7submit', anr_onloadCallback, false );
 if ( typeof jQuery !== 'undefined' ) {
 //Woocommerce
 jQuery( document.body ).on( 'checkout_error', anr_onloadCallback );
 }
 //token is valid for 2 minutes, So get new token every after 1 minutes 50 seconds
 setInterval(anr_onloadCallback, 110000);  } )( grecaptcha );
 </script></body></html>